Elevated Application errors

Incident Report for Juro

Resolved

This incident has been resolved.
Posted Feb 02, 2021 - 12:42 GMT

Investigating

We're experiencing an elevated level of application errors and are currently looking into the issue.
Posted Feb 02, 2021 - 12:42 GMT
This incident affected: Core services.