Degraded email signature functionality

Incident Report for Juro

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 06:58 GMT

Update

We are continuing to monitor for any further issues.
Posted Nov 19, 2025 - 06:57 GMT

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 17:30 GMT

Monitoring

Email functionally is restored. Our partner's outage continues.
Posted Nov 18, 2025 - 15:23 GMT

Identified

We are awaiting on the the partner service to recover.
Posted Nov 18, 2025 - 14:11 GMT

Investigating

Our email functionality related with the domain email.juro.com is degraded due to partner service(cloudflare) having a major incident.
Posted Nov 18, 2025 - 14:09 GMT
This incident affected: Core services.